Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2009
Syntax
C# |
---|
public void AddConstraintChordLength( ElementId paramId ) |
Visual Basic |
---|
Public Sub AddConstraintChordLength ( _ paramId As ElementId _ ) |
Visual C++ |
---|
public: void AddConstraintChordLength( ElementId^ paramId ) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
Remarks
The chord length is measured on the centerline of the bar.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |