RebarShapeDefinitionByArcAddConstraintChordLength Method |
Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddConstraintChordLength(
ElementId paramId
)
Public Sub AddConstraintChordLength (
paramId As ElementId
)
public:
void AddConstraintChordLength(
ElementId^ paramId
)
member AddConstraintChordLength :
paramId : ElementId -> unit
Parameters
- paramId ElementId
-
Id of a parameter to drive the constraint.
To obtain the id of a shared parameter,
call RebarShape.GetElementIdForExternalDefinition().
Exceptions
Remarks
The chord length is measured on the centerline of the bar.
See Also