Checks whether a string is an acceptable name for a Schema or a Field.
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool AcceptableName( string name ) |
Visual Basic |
---|
Public Function AcceptableName ( _ name As String _ ) As Boolean |
Visual C++ |
---|
public: bool AcceptableName( String^ name ) |
Parameters
- name
- Type: System..::..String
The string to check.
Return Value
True if the name is acceptable.
Remarks
For interoperability, names are required to be usable as C++ identifiers.
The allowable characters are ASCII letters, numbers (except the first character) and
underscore. The length must be between 1 and 247 characters.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |