SchemaBuilderAcceptableName Method |
Checks whether a string is an acceptable name for a Schema or a Field.
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AcceptableName(
string name
)
Public Function AcceptableName (
name As String
) As Boolean
public:
bool AcceptableName(
String^ name
)
member AcceptableName :
name : string -> bool
Parameters
- name String
-
The string to check.
Return Value
Boolean
True if the name is acceptable.
Exceptions
Remarks
For interoperability, names are required to be usable as C++ identifiers.
The allowable characters are ASCII letters, numbers (except the first character) and
underscore. The length must be between 1 and 247 characters.
See Also