Checks whether a field can be used with a global parameter-based filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public bool CanFilterByGlobalParameters( ScheduleFieldId fieldId ) |
Visual Basic |
---|
Public Function CanFilterByGlobalParameters ( _ fieldId As ScheduleFieldId _ ) As Boolean |
Visual C++ |
---|
public: bool CanFilterByGlobalParameters( ScheduleFieldId^ fieldId ) |
Parameters
- fieldId
- Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.
Return Value
True if the field can be used with a global parameter-based filter, false otherwise.
Remarks
The global parameter-based filter types are IsAsociatedWith, IsNotAssociatedWith.
Only parameters which have a compatible type with at least one existing global parameter can be filtered.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |