ScheduleDefinitionCanFilterByGlobalParameters Method |
Checks whether a field can be used with a global parameter-based filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanFilterByGlobalParameters(
ScheduleFieldId fieldId
)
Public Function CanFilterByGlobalParameters (
fieldId As ScheduleFieldId
) As Boolean
public:
bool CanFilterByGlobalParameters(
ScheduleFieldId^ fieldId
)
member CanFilterByGlobalParameters :
fieldId : ScheduleFieldId -> bool
Parameters
- fieldId ScheduleFieldId
-
The ID of the field to check.
Return Value
Boolean
True if the field can be used with a global parameter-based filter, false otherwise.
Exceptions
RemarksThe global parameter-based filter types are IsAsociatedWith, IsNotAssociatedWith.
Only parameters which have a compatible type with at least one existing global parameter
can be filtered.
See Also