Creates object from an array of domain point values
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public FieldValues( IList<ValueAtPoint> valueAtPoint ) |
Visual Basic |
---|
Public Sub New ( _ valueAtPoint As IList(Of ValueAtPoint) _ ) |
Visual C++ |
---|
public: FieldValues( IList<ValueAtPoint^>^ valueAtPoint ) |
Parameters
- valueAtPoint
- Type: System.Collections.Generic..::..IList<(Of <(<'ValueAtPoint>)>)>
Array of values, each corresponding to a domain point
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | valueAtPoint array contains members with different numbers of measurements |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |