ExtraCheckBoxText is used to label the extra checkbox.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public string ExtraCheckBoxText { get; set; } |
Visual Basic |
---|
Public Property ExtraCheckBoxText As String Get Set |
Visual C++ |
---|
public: property String^ ExtraCheckBoxText { String^ get (); void set (String^ value); } |
Remarks
If ExtraCheckBoxText is set, a checkbox with the text will be shown. You can get the response of checkbox by checking the return value of the WasExtraCheckBoxChecked() method.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the TaskDialog also has EnableMarqueeProgressBar set as the two cannot coincide in the same TaskDialog. |