GlobalParametersManagerMoveParameterDownOrder Method

Moves given paramerer Down in the current order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool MoveParameterDownOrder(
	Document document,
	ElementId parameterId
)

Parameters

document  Document
Document containing the give global parameter
parameterId  ElementId
The parameter to move Down

Return Value

Boolean
Indicates whether the parameter could be moved Down in order or not.
Exceptions
ExceptionCondition
ArgumentException Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families. -or- The input parameterId is not of a valid global parameter of the given document.
ArgumentNullException A non-optional argument was null
Remarks

A parameter can only be moved within its parameter group, meaning that repeated moving a parameter will not push the parameter out of and into the next (in order) parameter group. When a parameter can no longer move because it is at the boundary of its group, this method returns False.

This operation has no effect on the global parameters themselves. The rearranged order is only visible in the standard Global Parameters dialog. However, the order of parameters is serialized in the document, thus available on the DB level as well.

See Also