LevelFindAssociatedPlanViewId Method |
Finds the id of the first available associated floor or structural plan view associated with this level.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId FindAssociatedPlanViewId()
Public Function FindAssociatedPlanViewId As ElementId
public:
ElementId^ FindAssociatedPlanViewId()
member FindAssociatedPlanViewId : unit -> ElementId
Return Value
ElementId
Remarks
The view id returned is determined by the same rules associated with the Revit tool "Go to Floor Plan".
Many levels may actually have more than one associated floor plan id and this routine will only return
the first one found. If no associated view is found, InvalidElementId is returned.
See Also