DividedPathIsIntersectorValidForCreation Method |
This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsIntersectorValidForCreation(
Document document,
ElementId intersector
)
Public Shared Function IsIntersectorValidForCreation (
document As Document,
intersector As ElementId
) As Boolean
public:
static bool IsIntersectorValidForCreation(
Document^ document,
ElementId^ intersector
)
static member IsIntersectorValidForCreation :
document : Document *
intersector : ElementId -> bool
Parameters
- document Document
-
The document.
- intersector ElementId
-
The intersector.
Return Value
Boolean
True if the reference can be used to create a divided path, false otherwise.
Exceptions
Remarks
Intersectors can be curve elements, datum planes, or divided paths.
This function is should not be used to validate the input to SetIntersectors()
because it does not check for self intersection of any other circular dependencies between intersectors.
Use isIntersectorValidForDividedPath() instead.
See Also