RebarShapeDefinitionByArcAddConstraintSagittaLength Method |
Specify a parameter to drive the sagittal
length (the height of the circular segment, measured
perpendicular to the chord).
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddConstraintSagittaLength(
ElementId paramId
)
Public Sub AddConstraintSagittaLength (
paramId As ElementId
)
public:
void AddConstraintSagittaLength(
ElementId^ paramId
)
member AddConstraintSagittaLength :
paramId : ElementId -> unit
Parameters
- paramId ElementId
-
Id of a parameter to drive the constraint.
To obtain the id of a shared parameter,
call RebarShape.GetElementIdForExternalDefinition().
Exceptions
Remarks
The sagitta will be measured on the centerline of the bar.
See Also