RevitLinkGraphicsSettingsSetPhase Method |
Sets phase id and phase type of RevitLinkGraphicsSettings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetPhase(
LinkVisibility phaseType,
ElementId phaseId
)
Public Sub SetPhase (
phaseType As LinkVisibility,
phaseId As ElementId
)
public:
void SetPhase(
LinkVisibility phaseType,
ElementId^ phaseId
)
member SetPhase :
phaseType : LinkVisibility *
phaseId : ElementId -> unit
Parameters
- phaseType LinkVisibility
-
The type of the phase.
- phaseId ElementId
-
The id of the phase from the linked document or InvalidElementId.
If phaseType is set to ByHostView or ByLinkView the phaseId must be set to InvalidElementId.
If phaseType is set to Custom and phaseId is InvalidElementId the phase will reference to the last phase from the linked document.
Exceptions
See Also