TransactionGetStatus Method |
Returns the current status of the transaction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic TransactionStatus GetStatus()
Public Function GetStatus As TransactionStatus
public:
TransactionStatus GetStatus()
member GetStatus : unit -> TransactionStatus
Return Value
TransactionStatus
The current status of the transaction.
Remarks
If the status was set to TransactionStatus.Pending as the result of calling
Commit or RollBack, the status will be changed later to either 'Committed'
or 'RolledBack' after failure handling is finished. That status change will
be made asynchronously.
See Also