TransactionStatus Enumeration |
An enumerated type listing the possible statuses associated with a Transaction, TransactionGroup, or SubTransaction,
or the result of a particular method call on one of those objects.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum TransactionStatus
Public Enumeration TransactionStatus
public enum class TransactionStatus
MembersMember name | Value | Description |
---|
Uninitialized | 0 |
initial value, the transaction has not been started yet in this status
|
Started | 1 |
transaction has begun (until committed or rolled back)
|
RolledBack | 2 |
rolled back (aborted)
|
Committed | 3 |
simply committed, ended an empty transaction, flushed all, or undo is disabled
|
Pending | 4 |
returned from error handling that took over managing the transaction
|
Error | 5 |
error while committing or rolling back
|
Proceed | 6 |
while still in error handling (internal status)
|
See Also