DocumentExport(String, String, ICollectionElementId, DXFExportOptions) Method |
Exports a selection of views in DXF format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Export(
string folder,
string name,
ICollection<ElementId> views,
DXFExportOptions options
)
Public Function Export (
folder As String,
name As String,
views As ICollection(Of ElementId),
options As DXFExportOptions
) As Boolean
public:
bool Export(
String^ folder,
String^ name,
ICollection<ElementId^>^ views,
DXFExportOptions^ options
)
member Export :
folder : string *
name : string *
views : ICollection<ElementId> *
options : DXFExportOptions -> bool
Parameters
- folder String
-
Output folder, into which file(s) will be exported. The folder must exist.
- name String
-
Either the name of a single file or a prefix for a set of files.
If empty, automatic naming will be used.
- views ICollectionElementId
-
Selection of views to be exported. The set must contain at least one valid view.
- options DXFExportOptions
-
Various options applicable to the DXF format.
If , all options will be set to their respective default values.
Return Value
Boolean
True if successful, otherwise False.
Exceptions
Remarks
All the views must be printable for the Export to succeed.
It can be assured by checking the CanBePrinted property of each view.
See Also