PartMakerMethodToDivideVolumesDivisionRuleId Property |
Id of the 'DivisionRule' which is used to augment the cutting sketch.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId DivisionRuleId { get; set; }
Public Property DivisionRuleId As ElementId
Get
Set
public:
property ElementId^ DivisionRuleId {
ElementId^ get ();
void set (ElementId^ value);
}
member DivisionRuleId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The provided element id cannot be assigned as a division rule
to this PartMakerMethodToDivideVolumes.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also