VertexStreamPositionNormal Class

A stream that can be used to write vertices of type VertexPositionNormal into a buffer (see VertexBuffer).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.DirectContext3DVertexStream
    Autodesk.Revit.DB.DirectContext3DVertexStreamPositionNormal

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexStreamPositionNormal : VertexStream

The VertexStreamPositionNormal type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from VertexStream)
Top
Methods
 NameDescription
Public methodAddVertex Inserts a VertexStreamPositionNormal into the stream and associated buffer.
Public methodAddVertices Inserts multiple VertexStreamPositionNormal instances into the stream and associated buffer.
Public methodDispose
(Inherited from VertexStream)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also