AnalyticalPowerSourceDataVoltage Property |
Note: This API is now obsolete.
The voltage value of the analytical power source.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. The voltage is read only in Revit 2025 and assigned through the distribution system of the analytical power source, we suggest you use the 'AssignedVoltage' property instead.")]
public double Voltage { get; set; }
<ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. The voltage is read only in Revit 2025 and assigned through the distribution system of the analytical power source, we suggest you use the 'AssignedVoltage' property instead.")>
Public Property Voltage As Double
Get
Set
public:
[ObsoleteAttribute(L"This property is deprecated in Revit 2025 and may be removed in a later version of Revit. The voltage is read only in Revit 2025 and assigned through the distribution system of the analytical power source, we suggest you use the 'AssignedVoltage' property instead.")]
property double Voltage {
double get ();
void set (double value);
}
[<ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. The voltage is read only in Revit 2025 and assigned through the distribution system of the analytical power source, we suggest you use the 'AssignedVoltage' property instead.")>]
member Voltage : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The given value for voltage is not a number
-or-
When setting this property: The given value for voltage is not finite
|
ArgumentOutOfRangeException |
When setting this property: The given value for voltage must be positive.
|
InvalidOperationException |
When setting this property: The voltage on the analytical node is not editable.
|
See Also