TessellatedShapeBuilderTarget Enumeration |
Describes what TessellatedShapeBuilder
should generate, if possible.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum TessellatedShapeBuilderTarget
Public Enumeration TessellatedShapeBuilderTarget
public enum class TessellatedShapeBuilderTarget
type TessellatedShapeBuilderTarget
MembersMember name | Value | Description |
---|
Solid | 0 |
A solid, i.e., a Geometry, where all edges are shared by two and
only two faces and which divides all 3d space into bounded inner
and infinite outer area(s).
|
AnyGeometry | 1 |
A Geometry, which depending on input data can be a Solid or a 'sheet',
where there is no fully enclosed volume formed by the generated faces.
|
Mesh | 2 |
A mesh.
|
See Also