ViewScheduleGetDefaultNameForSchedule(Document, ElementId) Method |
Gets the default view name that will be used when creating a regular schedule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static string GetDefaultNameForSchedule(
Document document,
ElementId categoryId
)
Public Shared Function GetDefaultNameForSchedule (
document As Document,
categoryId As ElementId
) As String
public:
static String^ GetDefaultNameForSchedule(
Document^ document,
ElementId^ categoryId
)
static member GetDefaultNameForSchedule :
document : Document *
categoryId : ElementId -> string
Parameters
- document Document
-
The document to which the new schedule will be added.
- categoryId ElementId
-
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
Return Value
String
The default view name.
ExceptionsException | Condition |
---|
ArgumentException |
document is not a project document.
-or-
categoryId is not a valid category for a regular schedule.
-or-
The Areas category was specified but an area scheme ID was not provided.
|
ArgumentNullException |
A non-optional argument was null
|
See Also