DocumentNewSlabEdge(SlabEdgeType, ReferenceArray) Method |
Creates a slab edge along a reference array.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SlabEdge NewSlabEdge(
SlabEdgeType SlabEdgeType,
ReferenceArray references
)
Public Function NewSlabEdge (
SlabEdgeType As SlabEdgeType,
references As ReferenceArray
) As SlabEdge
public:
SlabEdge^ NewSlabEdge(
SlabEdgeType^ SlabEdgeType,
ReferenceArray^ references
)
member NewSlabEdge :
SlabEdgeType : SlabEdgeType *
references : ReferenceArray -> SlabEdge
Parameters
- SlabEdgeType SlabEdgeType
- The type of the slab edge to create
- references ReferenceArray
- An array of planar lines and arcs that represents the place where you
want to place the slab edge.
Return Value
SlabEdge If successful a new slab edge object within the project, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the slab edge type does not exist in the given document. |
See Also