MassInstanceUtilsGetGrossVolume Method

Get the total building volume represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static double GetGrossVolume(
	Document document,
	ElementId massInstanceId
)

Parameters

document  Document
The Document.
massInstanceId  ElementId
The ElementId of the mass instance.

Return Value

Double
The gross volume in cubic feet.
Exceptions
ExceptionCondition
ArgumentException The ElementId massInstanceId is not a mass instance.
ArgumentNullException A non-optional argument was null
See Also