DocumentNewCrossFitting Method |
Add a new family instance of a cross fitting into the Autodesk Revit document,
using four connectors.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstance NewCrossFitting(
Connector connector1,
Connector connector2,
Connector connector3,
Connector connector4
)
Public Function NewCrossFitting (
connector1 As Connector,
connector2 As Connector,
connector3 As Connector,
connector4 As Connector
) As FamilyInstance
public:
FamilyInstance^ NewCrossFitting(
Connector^ connector1,
Connector^ connector2,
Connector^ connector3,
Connector^ connector4
)
member NewCrossFitting :
connector1 : Connector *
connector2 : Connector *
connector3 : Connector *
connector4 : Connector -> FamilyInstance
Parameters
- connector1 Connector
- The first connector to be connected to the cross.
- connector2 Connector
- The second connector to be connected to the cross.
- connector3 Connector
- The third connector to be connected to the cross.
- connector4 Connector
- The fourth connector to be connected to the cross.
Return Value
FamilyInstanceIf creation was successful then an family instance to the new object is returned,
and the transition fitting will be added at the connectors' end if necessary,
otherwise an exception with failure information will be thrown.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument connector1, connector2, connector3, or connector4 is .
|
ArgumentException |
Thrown when the connectors cannot be used for cross creation. For example,
they cannot be from the same element, they must be of the same domain,
and the owner of the connectors should be a (flex) duct or pipe.
|
InvalidOperationException |
Thrown when cross fitting cannot be created.
|
See Also