RebarSpliceUtilsCanRebarBeSpliced(Rebar, RebarSpliceOptions, RebarSpliceGeometry) Method |
Verifies if the rebar can be spliced with the RebarSpliceGeometry.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static RebarSpliceError CanRebarBeSpliced(
Rebar rebar,
RebarSpliceOptions spliceOptions,
RebarSpliceGeometry spliceGeometry
)
Public Shared Function CanRebarBeSpliced (
rebar As Rebar,
spliceOptions As RebarSpliceOptions,
spliceGeometry As RebarSpliceGeometry
) As RebarSpliceError
public:
static RebarSpliceError CanRebarBeSpliced(
Rebar^ rebar,
RebarSpliceOptions^ spliceOptions,
RebarSpliceGeometry^ spliceGeometry
)
static member CanRebarBeSpliced :
rebar : Rebar *
spliceOptions : RebarSpliceOptions *
spliceGeometry : RebarSpliceGeometry -> RebarSpliceError
Parameters
- rebar Rebar
-
The rebar to be spliced.
- spliceOptions RebarSpliceOptions
-
The RebarSpliceOptions.
- spliceGeometry RebarSpliceGeometry
-
The RebarSpliceGeometry.
Return Value
RebarSpliceError
Will return RebarSpliceError.Success if it's possible to splice with point or other enum value corresponding to the error that occurred.
Exceptions
See Also