RebarInSystemGetTransformedCenterlineCurves Method |
A chain of curves representing the centerline of the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Curve> GetTransformedCenterlineCurves(
bool adjustForSelfIntersection,
bool suppressHooks,
bool suppressBendRadius,
int barPositionIndex
)
Public Function GetTransformedCenterlineCurves (
adjustForSelfIntersection As Boolean,
suppressHooks As Boolean,
suppressBendRadius As Boolean,
barPositionIndex As Integer
) As IList(Of Curve)
public:
IList<Curve^>^ GetTransformedCenterlineCurves(
bool adjustForSelfIntersection,
bool suppressHooks,
bool suppressBendRadius,
int barPositionIndex
)
member GetTransformedCenterlineCurves :
adjustForSelfIntersection : bool *
suppressHooks : bool *
suppressBendRadius : bool *
barPositionIndex : int -> IList<Curve>
Parameters
- adjustForSelfIntersection Boolean
-
If the curves overlap, as in a planar stirrup, this parameter controls
whether they should be adjusted to avoid intersection (as in fine views),
or kept in a single plane for simplicity (as in coarse views).
- suppressHooks Boolean
-
Identifies if the chain will include hooks curves.
- suppressBendRadius Boolean
-
Identifies if the connected chain will include unfilleted curves.
- barPositionIndex Int32
-
The bar index.
Return Value
IListCurve
The centerline curves or empty array if the curves cannot be computed because
the parameters values are inconsistent
with the constraints of the RebarShape definition.
Exceptions
Remarks
This method will return the centerline curves for bar at barPositionIndex even if this bar isn't included.
The curves are in the final position. The BarPositionTransform (representing the relative position of any individual bar in the set - a translation along the distribution path)
and MovedBarTransform (representing the movement of the bar relative to its default position along the distribution path) will be applied to the returned curves.
See Also