SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) Constructor |
Constructs a new calculator for the geometry of spatial elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SpatialElementGeometryCalculator(
Document aDoc,
SpatialElementBoundaryOptions options
)
Public Sub New (
aDoc As Document,
options As SpatialElementBoundaryOptions
)
public:
SpatialElementGeometryCalculator(
Document^ aDoc,
SpatialElementBoundaryOptions^ options
)
new :
aDoc : Document *
options : SpatialElementBoundaryOptions -> SpatialElementGeometryCalculator
Parameters
- aDoc Document
-
The document that contains the spatial elements.
- options SpatialElementBoundaryOptions
-
The options to control the calculation rules.
Exceptions
See Also