ViewShapeBuilderAddCurve Method

Add a curve to the GRep associated to this ViewShapeBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddCurve(
	Curve GCurve
)

Parameters

GCurve  Curve
The curve to be added.
Exceptions
ExceptionCondition
ArgumentException GCurve is not acceptable for view-specific shape representation that is currently being built.
ArgumentNullException A non-optional argument was null
See Also