ComponentRepeaterRemoveRepeaters Method |
Removes component repeaters from the document,
but leaves the individual repeated components in their respective locations and
hosted on their original hosts.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ISet<ElementId> RemoveRepeaters(
Document document,
ISet<ElementId> elementIds
)
Public Shared Function RemoveRepeaters (
document As Document,
elementIds As ISet(Of ElementId)
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ RemoveRepeaters(
Document^ document,
ISet<ElementId^>^ elementIds
)
static member RemoveRepeaters :
document : Document *
elementIds : ISet<ElementId> -> ISet<ElementId>
Parameters
- document Document
-
The document that contains the component repeaters to remove.
- elementIds ISetElementId
-
The set of component repeaters that should be removed.
Return Value
ISetElementId
A collection of components that were previously repeated by the component repeater.
ExceptionsException | Condition |
---|
ArgumentException |
The given element id set is empty.
-or-
One or more elements in elementIds do not exist in the document.
-or-
Not all given elements are component repeaters.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Remarks
In addition to the component repeaters the component repeater slots
are also removed from the document.
See Also