TopographySurfaceGetBoundaryPoints Method |
Gets the points which are on the boundary of the topography surface.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<XYZ> GetBoundaryPoints()
Public Function GetBoundaryPoints As IList(Of XYZ)
public:
IList<XYZ^>^ GetBoundaryPoints()
member GetBoundaryPoints : unit -> IList<XYZ>
Return Value
IListXYZ
The collection of boundary points.
Remarks
This applies to TopographySurface, SiteSubRegion, and the topography surface associated with a BuildingPad element.
For a SiteSubRegion, this returns the points from a representation of the region's boundary.
For the topography surface associated with a BuildingPad element, this returns the points from the sketch of this topography surface.
See Also