TopographySurfaceGetPoints Method |
Gets the points that define this topography surface.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<XYZ> GetPoints()
Public Function GetPoints As IList(Of XYZ)
public:
IList<XYZ^>^ GetPoints()
member GetPoints : unit -> IList<XYZ>
Return Value
IListXYZ
The collection of points.
Remarks
This applies to TopographySurface, SiteSubRegion, and the topography surface associated with a BuildingPad element.
For a SiteSubRegion, this returns the points from a representation of the region's boundary as well as the points inherited from the host TopographySurface.
For the topography surface associated with a BuildingPad element, this returns the points from the sketch of this topography surface(there are no interior points for this topography surface).
See Also