TableSectionDataSetCellType(Int32, Int32, CellType) Method |
Sets a cell's Type
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetCellType(
int nRow,
int nCol,
CellType type
)
Public Sub SetCellType (
nRow As Integer,
nCol As Integer,
type As CellType
)
public:
void SetCellType(
int nRow,
int nCol,
CellType type
)
member SetCellType :
nRow : int *
nCol : int *
type : CellType -> unit
Parameters
- nRow Int32
-
- nCol Int32
-
- type CellType
-
ExceptionsException | Condition |
---|
ArgumentException |
A CellType.CustomField can't be set.
-or-
The given row number nRow is invalid.
-or-
The given column number nCol is invalid.
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
This operation is forbidden for cells in standard schedule body sections.
|
See Also