SchemaBuilderAddArrayField Method

Creates a field containing an array of values in the Schema, with given name and type of contained values.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FieldBuilder AddArrayField(
	string fieldName,
	Type fieldType
)

Parameters

fieldName  String
The name of the new field.
fieldType  Type
The type of the contents in the new field.

Return Value

FieldBuilder
The FieldBuilder object may be used to add more details to the field. Make sure to set the unit type if the field contains floating-point values.
Exceptions
ExceptionCondition
ArgumentException The parameter fieldName is not acceptable for naming Extensible Storage objects. -or- The field type is not supported.
ArgumentNullException A non-optional argument was null
InvalidOperationException The SchemaBuilder has already finished building the Schema.
Remarks
The supported types for the contents are the same as for simple fields. See AddSimpleField(String, Type) for details.

Note that a schema may contain a maximum of 256 fields.

See Also