SchemaBuilderAddSimpleField Method

Creates a field containing a single value in the Schema, with given name and type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FieldBuilder AddSimpleField(
	string fieldName,
	Type fieldType
)

Parameters

fieldName  String
The name of the new field.
fieldType  Type
The type of the new field.

Return Value

FieldBuilder
The FieldBuilder object may be used to add more details to the field. Make sure to set the unit type if the field contains floating-point values.
Exceptions
ExceptionCondition
ArgumentException The parameter fieldName is not acceptable for naming Extensible Storage objects. -or- The field type is not supported.
ArgumentNullException A non-optional argument was null
InvalidOperationException The SchemaBuilder has already finished building the Schema.
Remarks

The supported types are Boolean, Byte, Int16, Int32, Int64, Float, Double, ElementId, GUID, String, XYZ, UV and Entity.

Note that data of type ElementId is not copied to new elements that are created via copy/paste or a linear or radial array.

Note that a schema may contain a maximum of 256 fields.

See Also