InCanvasControlData(String, XYZ) Constructor

Constructs an InCanvasControlData with specific values assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public InCanvasControlData(
	string imagePath,
	XYZ position
)

Parameters

imagePath  String
File path with the image to be used. This must be an absolute path to a location on disk.
position  XYZ
The position to be used.
Exceptions
ExceptionCondition
ArgumentException The file format specified by imagePath is an unsupported format - only *.bmp files are supported. -or- The file path specified by imagePath is not absolute.
ArgumentNullException A non-optional argument was null
FileArgumentNotFoundException The file specified by imagePath doesn't exist.
See Also