ParameterCanBeAssociatedWithGlobalParameter Method |
Tests whether this parameter can be associated with the given global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanBeAssociatedWithGlobalParameter(
ElementId gpId
)
Public Function CanBeAssociatedWithGlobalParameter (
gpId As ElementId
) As Boolean
public:
bool CanBeAssociatedWithGlobalParameter(
ElementId^ gpId
)
member CanBeAssociatedWithGlobalParameter :
gpId : ElementId -> bool
Parameters
- gpId ElementId
-
Id of a global parameter contained in this parameter's document
Return Value
Boolean
True if this parameter can be associated with the given global parameter; False otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
The input gpId is not of a valid global parameter of the given document.
-or-
This parameter does not exist in the document anymore.
|
ArgumentNullException |
A non-optional argument was NULL
|
Remarks
Only properties defined as parametrizable can be associated with global parameters.
That excludes any read-only and formula-driven parameters, as well as those that
have other explicit or implicit restrictions imposed by Revit.
See Also