ViewFamilyTypeIsValidDefaultTemplate Method |
Verifies that the input can be used as a default template for this view type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidDefaultTemplate(
ElementId templateId
)
Public Function IsValidDefaultTemplate (
templateId As ElementId
) As Boolean
public:
bool IsValidDefaultTemplate(
ElementId^ templateId
)
member IsValidDefaultTemplate :
templateId : ElementId -> bool
Parameters
- templateId ElementId
-
Id to be validated as default template.
Return Value
Boolean
True if %templateId% is valid as default template, false otherwise.
Exceptions
Remarks
The id must represent a template view that is compatible with this view type, or InvalidElementId.
See Also