ApplicationNewPointOnEdgeEdgeIntersection Method |
Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PointOnEdgeEdgeIntersection NewPointOnEdgeEdgeIntersection(
Reference edgeReference1,
Reference edgeReference2
)
Public Function NewPointOnEdgeEdgeIntersection (
edgeReference1 As Reference,
edgeReference2 As Reference
) As PointOnEdgeEdgeIntersection
public:
PointOnEdgeEdgeIntersection^ NewPointOnEdgeEdgeIntersection(
Reference^ edgeReference1,
Reference^ edgeReference2
)
member NewPointOnEdgeEdgeIntersection :
edgeReference1 : Reference *
edgeReference2 : Reference -> PointOnEdgeEdgeIntersection
Parameters
- edgeReference1 Reference
- The first edge reference.
- edgeReference2 Reference
- The second edge reference.
Return Value
PointOnEdgeEdgeIntersectionA new PointOnEdgeEdgeIntersection object.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument edgeReference1 or edgeReference2 is .
|
See Also