FilledRegionTypeBackgroundPatternId Property |
The background fill pattern Id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId BackgroundPatternId { get; set; }
Public Property BackgroundPatternId As ElementId
Get
Set
public:
property ElementId^ BackgroundPatternId {
ElementId^ get ();
void set (ElementId^ value);
}
member BackgroundPatternId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The patternId must either be InvalidElementId or represent a valid FillPatternElement.
-or-
When setting this property: The patternId must be a 'Drafting' pattern.
-or-
When setting this property: In a family the patternId can not be a solid fill pattern if the 'IsMasking' property is false.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
The FillPattern used for a background pattern must have a 'Drafting' target.
This applies to both project and family elements.
In addition, when the FilledRegionAttributes element is in a family, the pattern
cannot be the solid fill pattern unless the 'IsMasking' property is set to true.
InvalidElementId is used when there is no background pattern
See Also