ExportFontTableItem Property |
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExportFontInfo this[
ExportFontKey fontKey
] { get; set; }
Public Default Property Item (
fontKey As ExportFontKey
) As ExportFontInfo
Get
Set
public:
virtual property ExportFontInfo^ default[ExportFontKey^ fontKey] {
ExportFontInfo^ get (ExportFontKey^ fontKey) sealed;
void set (ExportFontKey^ fontKey, ExportFontInfo^ value) sealed;
}
abstract Item : ExportFontInfo with get, set
override Item : ExportFontInfo with get, set
Parameters
- fontKey ExportFontKey
-
Return Value
ExportFontInfo
A copy of the
ExportFontInfo.
ExceptionsException | Condition |
---|
ArgumentException |
When getting this property:
An entry with the given key is not present in the table.
|
Remarks
When getting this property, it returns a copy of the
ExportFontInfo from the table. In order to
make changes to the
ExportFontInfo and use those settings during export, set the modified
ExportFontInfo back into the table using the same key.
See Also