ExportFontKey Class

A key used to represent an item stored in an ExportFontTable.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExportFontKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportFontKey : IDisposable

The ExportFontKey type exposes the following members.

Constructors
 NameDescription
Public methodExportFontKey Constructs a new default ExportFontKey.
Public methodExportFontKey(ExportFontKey) Constructs a new copy of the input ExportFontKey object.
Public methodExportFontKey(String) Constructs a new ExportFontKey using an input font name.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyOriginalFontName The original font name.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExportFontKey
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also