ViewPlanCreateAreaPlan Method |
Creates a new area plan ViewPlan.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ViewPlan CreateAreaPlan(
Document document,
ElementId areaSchemeId,
ElementId levelId
)
Public Shared Function CreateAreaPlan (
document As Document,
areaSchemeId As ElementId,
levelId As ElementId
) As ViewPlan
public:
static ViewPlan^ CreateAreaPlan(
Document^ document,
ElementId^ areaSchemeId,
ElementId^ levelId
)
static member CreateAreaPlan :
document : Document *
areaSchemeId : ElementId *
levelId : ElementId -> ViewPlan
Parameters
- document Document
-
The document to which the area plan will be added.
- areaSchemeId ElementId
-
The id of the AreaScheme which will be used by the area plan.
- levelId ElementId
-
The id of the Level to associate with the area plan.
Return Value
ViewPlan
The new area plan ViewPlan.
ExceptionsException | Condition |
---|
ArgumentException |
The AreaScheme id is not valid and cannot be used for area plan views.
-or-
The ElementId levelId does not correspond to a Level.
-or-
Plan view creation is not allowed in this family.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also