HandRailTypeSupportLayout Property |
The support layout method of the handrail.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RailSupportsLayout SupportLayout { get; set; }
Public Property SupportLayout As RailSupportsLayout
Get
Set
public:
property RailSupportsLayout SupportLayout {
RailSupportsLayout get ();
void set (RailSupportsLayout value);
}
member SupportLayout : RailSupportsLayout with get, set
Property Value
RailSupportsLayout
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
When setting this property: The rail has no support specified so the data being set is not applicable.
|
See Also