CurveUVComputeDerivatives Method |
Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<UV> ComputeDerivatives(
double parameter,
bool normalized
)
Public Function ComputeDerivatives (
parameter As Double,
normalized As Boolean
) As IList(Of UV)
public:
IList<UV^>^ ComputeDerivatives(
double parameter,
bool normalized
)
member ComputeDerivatives :
parameter : float *
normalized : bool -> IList<UV>
Parameters
- parameter Double
-
The specified parameter along the curve.
- normalized Boolean
-
If false, parameter is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.
Return Value
IListUV
The array containing three members: the first derivative (at index [0]), the second derivative (at index [1]) and the unit tangent vector (at index [2]).
ExceptionsException | Condition |
---|
ArgumentException |
The given value for parameter is not finite
|
ArgumentOutOfRangeException |
The curve cannot be evaluated as normalized because it is unbound.
-or-
The parameter is not a valid value for normalized evaluation.
|
See Also