GradientBackgroundSettings Class

Represents the view gradient background settings.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBackgroundSettings
    Autodesk.Revit.DBGradientBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GradientBackgroundSettings : BackgroundSettings

The GradientBackgroundSettings type exposes the following members.

Properties
 NameDescription
Public propertyGroundColor The color of the ground.
Public propertyHorizonColor The color of the horizon.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BackgroundSettings)
Public propertySkyColor The color of the top of the sky.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from BackgroundSettings)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The colors of the background are interpolated for the pixels corresponding to the sky - from the "sky color" (top) to the "horizon color" (bottom). The ground is represented with a solid color ("ground color").
See Also