ProjectBrowserOptions Class

Provides access to settings that control Revit's Project Browser appearance and functionality.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIProjectBrowserOptions

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ProjectBrowserOptions : IDisposable

The ProjectBrowserOptions type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyShowViewPlacementOnSheetStatusIcons Show the icons indicating view placement on sheet status.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ProjectBrowserOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodStatic memberGetProjectBrowserOptions Returns the current Revit instance's ProjectBrowserOptions.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
These settings are stored in the Revit.ini file. All documents in Revit instances which use this Revit.ini will follow these settings.
See Also