Adds a filter to the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddFilter(
ElementId filterElementId
)
Public Sub AddFilter (
filterElementId As ElementId
)
public:
void AddFilter(
ElementId^ filterElementId
)
member AddFilter :
filterElementId : ElementId -> unit
Parameters
- filterElementId ElementId
-
ElementId of the filter.
ExceptionsException | Condition |
---|
ArgumentException |
ElementId is not associated with a FilterElement.
-or-
Filter is already applied to the view.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The element "this View" does not belong to a project document.
-or-
The view type does not support Visibility/Graphics Overriddes.
|
Remarks
The filter will be added with default overrides, which means that there will be no change in the view's display.
The filter is appended as the last filter in the order of filters applied to this view.
See Also