TemporaryGraphicsManagerUpdateControl Method

Updates the in-canvas control identified by the unique index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void UpdateControl(
	int index,
	InCanvasControlData data
)

Parameters

index  Int32
Unique index of the control to be updated.
data  InCanvasControlData
data to generate in-canvas control appearance.
Exceptions
ExceptionCondition
ArgumentException index is out of range of TemporaryGraphicsManager managed objects, or the indexed object has been removed from the document.
ArgumentNullException A non-optional argument was null
InvalidOperationException Failed to load the image from specified path.
See Also