PartMakerMethodToDivideVolumesCanBeDivisionProfile(ElementId, Document) Method |
Checks whether a family defines a profile which can be used by this method.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CanBeDivisionProfile(
ElementId familyId,
Document familyDocument
)
Public Shared Function CanBeDivisionProfile (
familyId As ElementId,
familyDocument As Document
) As Boolean
public:
static bool CanBeDivisionProfile(
ElementId^ familyId,
Document^ familyDocument
)
static member CanBeDivisionProfile :
familyId : ElementId *
familyDocument : Document -> bool
Parameters
- familyId ElementId
-
Element id of the family.
- familyDocument Document
-
The document containing the family to be tested.
Return Value
Boolean
True if the family defines a profile which can be used by a part maker,
false otherwise.
Exceptions
See Also