DocumentNewSpace(Phase) Method |
Creates a new unplaced space on a given phase.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Space NewSpace(
Phase phase
)
Public Function NewSpace (
phase As Phase
) As Space
public:
Space^ NewSpace(
Phase^ phase
)
member NewSpace :
phase : Phase -> Space
Parameters
- phase Phase
- The phase in which the space is to exist.
Return Value
Space If successful the new space should be returned, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the phase does not exist in the given document. |
See Also